Payment method issue

Incident Report for Storable Easy

Resolved

This issue has been resolved. You can now add new ACH accounts as payment methods. Thank you for your patience and for using Storable Easy.
Posted Apr 03, 2025 - 18:32 EDT

Identified

The issue has been identified and a fix is in progress. Thank you for your patience.
Posted Apr 03, 2025 - 17:42 EDT

Investigating

We are aware of an issue preventing users from adding new ACH accounts as a payment method. We are investigating the issue and will provide updates as we work toward a resolution. We apologize for the inconvenience and thank you for your patience.
Posted Apr 03, 2025 - 14:13 EDT
This incident affected: Easy Payments.