Storable Payments - Unable to process refunds

Incident Report for Storable Easy

Resolved

Refund processing for Storable Payments customers is working normally again. Thanks for your patience as our team fixed this issue.
Posted Apr 02, 2026 - 09:15 EDT

Investigating

We're aware of an issue temporarily preventing Storable Payments customers from processing refunds. We're actively working to implement a solution and will provide updates as soon as they're available.
Posted Apr 01, 2026 - 12:49 EDT
This incident affected: Storable Payments.